Презентация на тему Начала информатики. Алгоритмический язык программирования ЛОГО. Методическая разработка учителя информатики Солодовниковой Т. Я. Начала.

Презентация на тему Презентация на тему Начала информатики. Алгоритмический язык программирования ЛОГО. Методическая разработка учителя информатики Солодовниковой Т. Я. Начала., предмет презентации: Разное. Этот материал содержит 107 слайдов. Красочные слайды и илюстрации помогут Вам заинтересовать свою аудиторию. Для просмотра воспользуйтесь проигрывателем, если материал оказался полезным для Вас - поделитесь им с друзьями с помощью социальных кнопок и добавьте наш сайт презентаций ThePresentation.ru в закладки!

Слайды и текст этой презентации

Слайд 1
Текст слайда:

Начала информатики. Алгоритмический язык программирования ЛОГО. Методическая разработка - презентация учителя информатики Солодовниковой Т. Я.





Слайд 2
Текст слайда:

Цели: 1. Познакомить с понятиями алгоритм и программа. 2. Познакомить с командами алгоритмического языка ЛОГО. 3. Пробудить желание экспериментировать. Задачи: 1. Научить общению с компьютером в режиме диалога на языке ЛОГО. 2. Научить основам программирования на алгоритмическом языке ЛОГО. 3. Развивать алгоритмическое мышление.





Слайд 3
Текст слайда:

Темы уроков.

Урок 1. Введение.
Урок 2. Углы и их измерение.
Урок 3. «Черепашья графика».
Урок 4. Ритм и повторение.
Урок 5. Построение правильных многоугольников.
Урок 6. Построение окружности и дуги.
Урок 7. Процедуры.
Урок 8. Процедуры с параметрами.
Урок 9. Рекурсивные процедуры.
Урок 10. Координаты.












Слайд 4
Текст слайда:

Думаем и исследуем на ЛОГО.





Слайд 5
Текст слайда:

Урок 1. Введение.



Слайд 6
Текст слайда:

Немного истории…

Язык программирования ЛОГО был разработан в конце
60-х годов американским исследователем в области
искусственного интеллекта С. Пейпертом.

Название языка происходит от греческого слова «LOGOS» - «слово», «мысль», «смысл», «идея».


В языке используется
специальный исполнитель
команд
«черепашка».

Она точно выполняет
все команды учащегося.




Слайд 7
Текст слайда:

Алгоритм и программа - основные понятия информатики.

Алгоритм – конечная последовательность шагов в решении задачи, приводящая от исходных данных к требуемому результату.
Алгоритм можно записать в виде нумерованного списка
(словесная форма) или изобразить с помощью
блок-схемы.
Программа – это алгоритм, записанный на языке
программирования.

Уметь программировать – значит
строить алгоритм, т. е.
последовательность команд,
приводящих к нужному результату, и
правильно записывать команды на
языке программирования.


Слайд 8
Текст слайда:

Базовые команды черепашки.


Черепашку можно научить многим командам, но она имеет и некоторый начальный уровень образованности и выполняет следующие базовые команды

вперед, назад, направо, налево.



Слайд 9
Текст слайда:

Запомни:

Для выполнения команд вперед и назад необходимо задать черепашке количество шагов (число).

Для выполнения команд направо и налево необходимо указать черепашке, на сколько градусов повернуться (число), считая от её текущего положения.

Между командой и числом ставится пробел.



Слайд 10
Текст слайда:

Выполним:







вперед 100






















Слайд 11
Текст слайда:

Выполним:



назад 100


Слайд 12
Текст слайда:

Выполним:



направо 90


Слайд 13
Текст слайда:

Выполним:



налево 90


Слайд 14
Текст слайда:

Выполним в программе ЛОГОМИРЫ:




Слайд 15
Текст слайда:

Урок 2. Углы и их измерение.


Слайд 16
Текст слайда:


Прежде чем попросить
черепашку двигаться,
нужно обратить внимание на её
ориентацию и положение.


Слайд 17
Текст слайда:

Запомни:

Ориентацией черепашки называют то
направление,
куда устремлён её носик.

Положение черепашки – это та точка
экрана,
в которой она находится.


Слайд 18
Текст слайда:

Черепашка, повернись!



Черепашка двигаясь по экрану,
должна выдержать заданное направление.
Поэтому перед движением обязательно
задаётся направление движения.


Слайд 19
Текст слайда:

Направо


с

ю

в

з

00

900

1800

2700

3600


Слайд 20
Текст слайда:

Налево


с

ю

в

з

00

900

1800

2700

3600


Слайд 21
Текст слайда:

Измерить можно - длину отрезка на листе бумаги, - расстояние между городами, - время, - скорость движения поезда, - силу электрического тока, - влажность воздуха, - громкость звука, - температуру окружающей среды, - освещённость помещения и т. д.





Сегодня мы научимся измерять угловые
величины.

Повернём стрелку направо
и отметим её новое положение.
Между исходной и повёрнутой стрелками
образовался угол.
Этот угол обозначен цифрой 1.

1



Слайд 22
Текст слайда:

Чтобы точно сравнивать углы и определять их величину, надо научиться их измерять.

Посмотрим на часы:

По циферблату бежит секундная стрелка.
Условимся считать начальным положением
стрелки самую верхнюю точку циферблата,
отмеченную числом 12.

Стрелка побежала от начального положения и угол между её начальным
положением и текущим положением стал увеличиваться.
Угол растёт до тех пор, пока стрелка не пробежит полный круг.

Стрелка пробежала полный круг и оказалась
опять в точке циферблата, отмеченной числом 12.

Такой угол, который соответствует полному обороту стрелки, считают
равным 360 градусам.


12

3

9

6















Слайд 23
Текст слайда:

Измерение углов.

Угол, который описывается стрелкой, пробежавшей
полкруга, равен 180 градусам.
Угол, который описывается стрелкой, пробежавшей
четверть круга, равен 90 градусам.
Угол, равный 1 градусу, это очень маленький угол,
но можно измерять и меньшие углы. Однако мы не
будем использовать такие маленькие углы.

Углы можно складывать.
Например: один угол равен 90 градусов, а второй угол
равен 45 градусам.
Сумма этих углов будет равна 135 градусам.


Слайд 24
Текст слайда:

Углы бывают:


900

прямые


Слайд 25
Текст слайда:

Углы бывают:


450

450

300

300

300

300

600

острые


Слайд 26
Текст слайда:

Углы бывают:



1800

1350

тупые

развёрнутые



Слайд 27
Текст слайда:

Урок 3. «Черепашья» графика.


Слайд 28
Текст слайда:

Язык ЛОГО имеет большие графические возможности.

Перемещаясь по экрану компьютера черепашка может оставлять след, подобно живой черепахе, которая волочит свой хвост по песку.
Эту её способность мы будем использовать, чтобы чертить фигуры на экране.


Слайд 29
Текст слайда:

Запомни:

Черепашка может двигаться по экрану оставляя след, а может и не оставлять след.

Чтобы черепашка оставляла след нужно дать команду
Перо Опусти – ПО

Чтобы черепашка не оставляла след нужно дать команду
Перо Подними – ПП



Слайд 30
Текст слайда:

Задание 1.


Научим черепаху рисовать прямоугольник.

Одна сторона этого прямоугольника будет 100 шагов,
другая - 160 шагов. Все углы у прямоугольника - прямые, значит
повороты черепашки при переходе со стороны на сторону
будут 90 градусов.




160

100

900

900


Слайд 31
Текст слайда:

Составим алгоритм в виде нумерованного списка (словесная форма):

Начало.
Вперёд на величину ширины прямоугольника.
Поворот на 900 вправо.
Вперёд на величину длины прямоугольника.
Поворот на 900 вправо.
Вперёд на величину ширины прямоугольника.
Поворот на 900 вправо.
Вперёд на величину длины прямоугольника.
Поворот на 900 вправо.
Конец.



Слайд 32
Текст слайда:

Черепаха, шагом марш!


Напишем программу на языке ЛОГО:

по
вперед 100
направо 90

вперед 160
направо 90

вперед 100
направо 90

вперед 160
направо 90
Выполним в программе
ЛОГОМИРЫ:



Слайд 33
Текст слайда:

Задание 2.

А теперь нарисуем квадрат. У квадрата все стороны равны.
Сторона квадрата будет 100 шагов.


по
вперед 100
направо 90

вперед 100
направо 90

вперед 100
направо 90

вперед 100
направо 90
Выполним в программе
ЛОГОМИРЫ:


100

900

900



Слайд 34
Текст слайда:

Программировать – значит и редактировать.

При построении прямоугольника и квадрата черепашка двигалась,
поворачиваясь только
Направо.

Теперь попросим её нарисовать такие же фигуры,
но поворачиваясь только
Налево.
Для этого отредактируем наши программы,
т. е. заменим команду Направо на команду Налево.


Слайд 35
Текст слайда:


Задание 3.
Нарисуем лесенку с тремя ступенями.
Размер ступеньки по ширине и высоте равен 20.
В этом задании черепашка будет двигаться поворачиваясь налево и
направо.
по
вперед 20
направо 90
вперед 20

налево 90
вперед 20
направо 90

вперед 20
налево 90
вперед 20
Выполним в программе ЛОГОМИРЫ:
направо 90
вперед 20
налево 90



Слайд 36
Текст слайда:

Задание 4.

Построим равносторонний треугольник.
Длина стороны 100 шагов.
Все углы в равностороннем
треугольнике равны 600 .

Составим алгоритм в виде блок-схемы.




100

600

600

600

1200

120 0

1200







Начало

Вперед на 100 шагов

Направо на 1200

Вперед на 100 шагов

Вперед на 100 шагов



Направона 1200

Направо на 1200

Конец

Блок-схема


Слайд 37
Текст слайда:

Напишем программу на языке ЛОГО:

по
вперед 100
направо 120

вперед 100
направо 120

вперед 100
направо 120


Выполним в программе
ЛОГОМИРЫ:




Слайд 38
Текст слайда:

Задание 5.

Построим уголок. Длина линии 50 шагов.

по
направо 45
вперед 50
направо 90
вперед 50
налево 90

Выполним в программе ЛОГОМИРЫ:






450

900

50

900



Слайд 39
Текст слайда:

Задание 6.


Построим фигуру. Длина линии 50 шагов. Угол поворота 900 .


по
вперед 50
направо 90

вперед 50
направо 90

вперед 50
налево 90
вперед 50
налево 90


Выполним в программе ЛОГОМИРЫ

50

900

900

900




Слайд 40
Текст слайда:

Урок 4. Ритм и повторение.


Слайд 41
Текст слайда:

Окружающий нас мир полон ритмов.

Есть свой ритм в звуке шагов,
в стуке и грохоте машин,
в пении птиц.
Ритмично сменяют друг друга дни и ночи,
дни недели,
времена года.
Этот ритм задаётся движением Земли.

Ритм лежит в основе музыки.
Ритм в музыке задаётся тактом.

Ритм неотступно сопровождает каждого их нас с первой
до последней минуты жизни – это ритм бьющегося
сердца.


Слайд 42
Текст слайда:



Ритм – это многократное повторение
чего – либо.


В программировании повторение называется ЦИКЛОМ.


В программировании повторяться могут только команды.


В ЛОГО – повторение некоторое количество раз одной или нескольких команд обеспечивает команда

Повтори


Слайд 43
Текст слайда:

Запомни:


Заключённая в квадратные скобки последовательность команд называется телом цикла.

При выполнении команды цикла, тело повторяется столько раз, сколько
указывает число, стоящее после слова Повтори.

Например:
Повтори 4[Вперед 100 Направо 90]




Слайд 44
Текст слайда:

Используем команду Повтори для построения фигур. Пример 1.


Для построения квадрата команда черепашке будет
выглядеть так:

повтори 4 [вперед 100 направо 90]


Слайд 45
Текст слайда:

Пример 2.


Для построения треугольника
команда черепашке будет
выглядеть так:

повтори 3 [вперед 100 направо 120]


Слайд 46
Текст слайда:

Пример 3.

Для построения пяти уголков команда черепашке будет
выглядеть так:

направо 45
повтори 5 [вперед 50 направо 90 вперед 50 налево 90]



Слайд 47
Текст слайда:

Пример 4.

Начертим вертикальную пунктирную линию.
Линия содержит 10 пунктиров,
длина каждого пунктира 10,
расстояние между пунктирами 5.


повтори 10 [по вперед 10 пп вперед 5 ]











Повторяющаяся часть рисунка

10

5


Слайд 48
Текст слайда:

Пример 5.

Начертим горизонтальную пунктирную линию.
Линия содержит 10 пунктиров,
длина каждого пунктира 10, расстояние между пунктирами 5.


направо 90
повтори 10 [по вперед 10 пп вперед 5 ]











900


Слайд 49
Текст слайда:

Пример 6.

Какую фигуру начертит черепаха после
выполнения команд:

по
повтори 2 [вперед 50 направо 90
вперед 50 направо 90 вперед 50
налево 90 вперед 50 налево 90]


Слайд 50
Текст слайда:

Черепаха начертит:


Слайд 51
Текст слайда:

Пример 7.

Какую фигуру начертит черепаха после
выполнения команд:

по
повтори 5 [вперед 50 направо 90
вперед 50 налево 90]


Слайд 52
Текст слайда:

Черепаха начертит:



Слайд 53
Текст слайда:

Урок 5.

Построение правильных многоугольников.


Слайд 54
Текст слайда:


Правильными называются многоугольники,
у которых все стороны и углы равны.




Чтобы построить любой правильный многоугольник,
воспользуемся командой
повтори.


Слайд 55
Текст слайда:

Получим значение угла поворота.

Для этого
3600 (число градусов в полном круге) разделим на
N (число углов многоугольника)
360/N




Слайд 56
Текст слайда:

Получим значение угла поворота:

360/3=120 – для треугольника
360/4=90 – для прямоугольника
360/5=72 – для пятиугольника
360/6=60 – для шестиугольника
360/8=45 – для восьмиугольника


Слайд 57
Текст слайда:

Построим фигуры.


1. Правильный треугольник:
повтори 3[ вперед 100 направо 120]

2. Правильный прямоугольник:
повтори 4 [вперед 100 направо 90]




Слайд 58
Текст слайда:

Построим фигуры.

3. Правильный пятиугольник:
повтори 5[вперед 100 направо 72]

4. Правильный шестиугольник:
повтори 6[вперед 100 направо 60]

5. Правильный восьмиугольник:
повтори 8[вперед 100 направо 45]




Выполним в программе ЛОГОМИРЫ:





Пятиугольник

Шестиугольник

Восьмиугольник



Слайд 59
Текст слайда:

Урок 6.

Построение окружности.


Слайд 60
Текст слайда:


Любую окружность можно считать
правильным многоугольником с очень малой
стороной и соответственно очень малым
углом поворота.

Для построения окружности будем использовать команду повтори.


Слайд 61
Текст слайда:

Формула окружности.

Для значения угла поворота, равного N, получим
формулу окружности:



Построим окружность в виде 360-угольника.
Найдём угол поворота: 3600/360 = 10
Длину стороны возьмём за 1шаг.
Используем команду:
повтори 360[вперед 1 направо 1]


Выполним в программе ЛОГОМИРЫ:


повтори 360/N [вперед 1 направо N]



Слайд 62
Текст слайда:

Пользуясь формулой окружности заполним таблицы:





Уменьшение Увеличение
окружности: окружности:




Слайд 63
Текст слайда:

Построим окружности разного размера пользуясь данными таблиц:

Повтори 180 [вперед 1 направо 2]

Повтори 400 [ вперед 1 направо 0.9]

Повтори 36 [ вперед 1 направо 10]

Повтори 514 [ вперед 1 направо 0.7]

Повтори 120 [ вперед 1 направо 3]


Слайд 64
Текст слайда:

Построение дуги.

Дуга – это часть окружности.




Слайд 65
Текст слайда:



Например:

1. Эта дуга – половина окружности, поэтому количество
повторений надо уменьшить в два раза:

повтори 180 [вперед 1 направо 1]





2. Эта дуга – четверть окружности, поэтому количество
повторений надо уменьшить в четыре раза:

повтори 90 [вперед 1 направо 1]


1800

900


Слайд 66
Текст слайда:

Задание.

Построить дугу, которая составляет восьмую часть
окружности.

повтори 45 [вперед 1 направо 1]




Выполним в программе ЛОГОМИРЫ.




Слайд 67
Текст слайда:

Урок 7.

Процедуры.



Слайд 68
Текст слайда:


Процедура – это программа,
т. е. последовательность
известных черепашке (базовых)
команд, имеющая имя.


По этому имени процедуру можно
вызывать,
т. е. выполнять все входящие в неё
команды.



Слайд 69
Текст слайда:

Запомни:

Процедура состоит из трёх частей:
1. Заголовок процедуры.
2. Тело процедуры (описание).
3. Окончание процедуры.



Слайд 70
Текст слайда:

Запомни:

Заголовок процедуры пишется на отдельной
строке и составляется из
обязательного слова ЭТО,
за которым указывается имя
процедуры.
Тело процедуры – все команды,
расположенные между заголовком
и окончанием.
Окончание процедуры – слово КОНЕЦ.


Слайд 71
Текст слайда:

Вызов процедуры. Имя процедуры, использованное в качестве команды, называется вызовом процедуры.




Слайд 72
Текст слайда:

Задание 1.

Составим процедуру квадрат:

это квадрат
по
повтори 4 [вперед 100 направо 90]
конец

Вызов процедуры - квадрат




Слайд 73
Текст слайда:

Задание 2.

С помощью процедуры квадрат изобразить квадрат,
повёрнутый на 45 градусов:


направо 45
квадрат



Слайд 74
Текст слайда:

Задание 3.

Используя процедуру квадрат заставить квадрат
покружиться на месте:


повтори 18 [квадрат направо 20]


Слайд 75
Текст слайда:

Задание 4.

Составить процедуру дуга и используя эту процедуру
нарисовать лепесток .
это дуга
по
повтори 45 [вперед 1 направо 2]
конец

дуга направо 90 дуга






Слайд 76
Текст слайда:

Задание 5.


Имея описание процедуры дуга напишите программу,
которая рисует цветочек, состоящий из четырёх лепестков:






Слайд 77
Текст слайда:

Программа на ЛОГО:

это дуга
по
повтори 45[ вперед 1 направо 2]
конец


повтори 4 [дуга направо 90 дуга]


Слайд 78
Текст слайда:

Задание 6.



Имея описание процедуры дуга, нарисовать море:


Слайд 79
Текст слайда:

Программа на ЛОГО:

это дуга
по
повтори 180 [вперед 1 направо 1]
конец

повтори 5 [дуга налево 180]



Слайд 80
Текст слайда:

Урок 8.

Процедуры и параметры.




Слайд 81
Текст слайда:


Составим программу - процедуру, которая будет рисовать квадрат, но вместо
конкретного количества шагов, определяющего размер квадрата,
поставим параметр - переменную, значение которой можно изменять.



Слайд 82
Текст слайда:

Процедура с параметром:

это квадрат :сторона
повтори 4 [вперед :сторона направо 90]
конец

Параметр :сторона указан в заголовке процедуры
вслед за её именем.

Этот же параметр встречается (обязательно) и в теле
процедуры, в том месте, где предусмотрено
использование переменной величины.


Слайд 83
Текст слайда:

Запомни:

Параметр - переменную можно представить себе как ящик, на котором написано имя, а внутри находится значение.
Это значение можно изменять.



Перед именем переменной ставится двоеточие,
пробел между двоеточием и именем переменной
не допускается.




Слайд 84
Текст слайда:

Переменные в процедурах называются параметрами. - Значения параметров внутри процедуры не меняются. - Параметры, указываемые в описании процедуры ( в её заголовке и в теле), называют формальными параметрами её описания. - Формальный параметр всегда представляет собой имя некоторой величины.


Слайд 85
Текст слайда:

Запомни:

В момент вызова процедуры с параметрами
надо указать значение этого параметра:
квадрат 100


Это значит, что значение переменной
для команды вперед следует взять из
переменной сторона,
которая стоит в заголовке процедуры.




Слайд 86
Текст слайда:

Значение величины, указываемое при вызове процедуры называется фактическим параметром или параметром вызова процедуры.

Фактический параметр всегда является значением,
заменяющим собой формальный параметр в описании
процедуры;
с этим значением параметра и выполняется вызванная
процедура.


Слайд 87
Текст слайда:

Процедура с несколькими параметрами.

Пример 1.
Составим описание процедуры, рисующей прямоугольник,
длина и высота которого произвольны:

это прямоугольник :высота :длина
повтори 2 [вперед :высота направо 90
вперед :длина направо 90]
конец

Вызов процедуры: прямоугольник 50 100


прямоугольник


Слайд 88
Текст слайда:

Пример 2.

Составим процедуру, которая будет рисовать любой
правильный многоугольник, но вместо конкретного
количества повторений, количества шагов и угла поворота
поставим переменные, значение которых можно изменять:

это многоугольник :число :сторона :угол
повтори :число [вперед :сторона направо :угол]
конец

Вызов процедуры: многоугольник 6 100 60

шестиугольник



Слайд 89
Текст слайда:

Урок 9.

Рекурсивные процедуры


Слайд 90
Текст слайда:

Мы уже знаем, как заставить черепаху начертить круговую орбиту:
это орбита
повтори 360 [ вперед 1 направо 1]
конец
Но как заставить её кружить по этой орбите подобно спутнику?

Для этого после того, как черепаха начертит окружность, она снова
должна выполнить процедуру орбита:
это орбита
повтори 360 [вперед 1 направо 1]
орбита
конец



Слайд 91
Текст слайда:

Запомни:


Процедуры которые вызывают сами себя
называются рекурсивными.


Слайд 92
Текст слайда:

Рекурсивная процедура выполняется бесконечно…

Прервать программу можно
одновременным нажатием клавиш и


Слайд 93
Текст слайда:

Бесконечное движение черепашки по треугольной орбите:

это треугольник
повтори 3 [вперед 100 направо 120]
треугольник
конец


Слайд 94
Текст слайда:

Бесконечное движение черепашки по квадратной орбите:

это квадрат
повтори 4 [вперед 100 направо 90]
квадрат
конец



Слайд 95
Текст слайда:

Урок 10.

Координаты.


Слайд 96
Текст слайда:

Запомни:

Два числа, определяющие положение точки на плоскости,
называются координатами.

Плоскость с отмеченной на ней точкой начала отсчёта и
проходящими через эту точку двумя линиями, называется
системой координат.

Точку начала отсчёта называют началом координат.

Направленные линии – осями координат.


Слайд 97
Текст слайда:

Запомни:


Для того, чтобы точка могла быть точно
определена парой координат, первым
элементом пары всегда является
величина Х (абсцисса точки),
а вторым элементом – всегда величина
У (ордината точки).


Слайд 98
Текст слайда:


(0, 0)

у

х

Ось абсцисс

Ось ординат


А(х, у)

372

213

-372

-213

Размеры экрана:

II четверть

I четверть

III четверть

IV четверть


Слайд 99
Текст слайда:

Оси координат разбивают плоскость на четыре части, которые называются координатными четвертями.

Мы будем работать только в первой
координатной четверти

у

х

I четверть

Координаты центра экрана [0 0]


Слайд 100
Текст слайда:

Внимание!

Решая задачи с использованием
координат, мы не будем пользоваться
командами вперед, назад,
направо, налево.



Новые команды:

покажи место – сообщает координаты точки, в которой
находиться черепашка;
нов_место [х у] – перемещает черепашку в точку
с координатами [х у];
нов_у число – изменяет у-координату черепашки;
нов_х число – изменяет х-координату черепашки;


Передвигаясь от точки к точке черепашка может оставлять
след, а может не оставлять след.


Слайд 101
Текст слайда:

Пример 1.

Построить квадрат, пользуясь координатами его вершин.


(0,0)

10


60

10

60

у

х

(10,10)

(10,60)

(60,60)

(60,10)

пп
нов_место [10 10]
по
нов_место [10 60]
нов_место [60 60]
нов_место [60 10]
нов_место [10 10]

Программа на ЛОГО:


Слайд 102
Текст слайда:

Программа на ЛОГО
2ой вариант:

пп
нов_место [10 10]
по
нов_у 60
нов_х 60
нов_у 10
нов_х 10


Слайд 103
Текст слайда:

Пример 2.

Даны координаты пятнадцати точек.
Построить фигуру по этим координатам.

(40,10)
(40,20)
(10,20)
(40,50)
(20,50)
(40,70)
(30,70)
(50,90)
(70,70)
(60,70)
(80,50)
(60,50)
(90,20)
(60,20)
(60,10)

пп
нов_место [40 10]
по
нов_место [ 40 20 ]
нов_место [ 10 2 0]
нов_место [ 40 5 0]
нов_место [ 20 50 ]
нов_место [ 40 70 ]
нов_место [ 30 70 ]
нов_место [ 50 9 0]
нов_место [ 70 70 ]
нов_место [ 60 7 0]
нов_место [ 80 5 0]
нов_место [ 60 5 0]
нов_место [ 90 20 ]
нов_место [ 60 20 ]
нов_место [ 60 10 ]

Программа на ЛОГО:


Слайд 104
Текст слайда:

Черепашка построит:

х

у

0


Слайд 105
Текст слайда:

Пример 3.

Даны координаты двенадцати точек.
Построить фигуру по этим координатам.
(30, 60)
(60, 30)
(150, 30)
(180, 60)
(100, 60)
(100, 160)
(130, 160)
(120, 150)
(130, 140)
(100, 140)
(160, 60)
(30, 60)

Программа на ЛОГО:

пп
нов_место [30 60]
По
нов_место [ 60 30]
нов_место [ 150 30]
нов_место [ 180 60]
нов_место [ 100 60]
нов_место [ 100 160]
нов_место [ 130 160]
нов_место [ 120 150]
нов_место [ 130 140]
нов_место [ 100 140]
нов_место [ 160 60]
нов_место [ 30 60]


Слайд 106
Текст слайда:

Черепашка построит:

х

у

0


Слайд 107
Текст слайда:

Слышу – и забываю, вижу – и запоминаю, делаю – и понимаю. (Восточная мудрость)



Обратная связь

Если не удалось найти и скачать презентацию, Вы можете заказать его на нашем сайте. Мы постараемся найти нужный Вам материал и отправим по электронной почте. Не стесняйтесь обращаться к нам, если у вас возникли вопросы или пожелания:

Email: Нажмите что бы посмотреть 

Что такое ThePresentation.ru?

Это сайт презентаций, докладов, проектов, шаблонов в формате PowerPoint. Мы помогаем школьникам, студентам, учителям, преподавателям хранить и обмениваться учебными материалами с другими пользователями.


Для правообладателей

Яндекс.Метрика